Articles of update manager

Ошибка обновления программного обеспечения, а «apt-get update» выбрасывает «Недействительное обновление операции» – что дальше?

Я запускаю довольно ванильный 14.04 Ubuntu на новом рабочем столе HP. Только вчера я получил страшный «Не удалось загрузить информацию репозитория»: Снимок экрана этого окна был замечен на AskUbuntu раньше. Я проверил связанные темы здесь, а также посмотрел полезную статью за пределами сайта . Странная вещь заключается в том, что когда я запускаю sudo apt-get […]

Программное обеспечение и обновления (software-properties-gtk): «EOFError: данные маршала слишком короткие»

Я не могу открыть инструмент Software & Updates 14.04 и получить следующую ошибку: Вот полный вывод apt-get update , он показывает это предупреждение: W: GPG error: http://dl.bintray.com Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 99E82A75642AC823 Когда я запускаю sudo software-properties-gtk , я получаю эту трассировку ошибок . […]

Ошибка импорта при запуске диспетчера обновлений

Похоже, я получаю некоторую ошибку, связанную с Python, но я не уверен, почему я ее получаю. Когда я запускал Software Updater (в 12.10) из единицы, он даже не запускался. Когда я сделал это с терминала: sudo update-manager Я получаю эту трассировку, и диспетчер обновлений даже не открывается. Я не думаю, что это ошибка, поэтому я […]

Менеджер обновлений обновляет модем ядра, но не клиент nvidia, как заставить их соответствовать?

Обновление 12.04 на 2012-12-22 обновило ядро ​​до 3.2.0-35-generic и попыталось обновить драйвер nvidia до nvidia-experimental-310 310.14-0ubuntu0.1, но этого не произошло. Обновление диспетчера обновлений 2013-01-06 обновило модуль ядра до nvidia-experimental-310 310.14-0ubuntu0.1, но, по-видимому, не обновил фактический драйвер, оставив его на уровне 304.43. Поэтому после обновления X не удается из-за несоответствия драйвера мод / графику ядра. Это […]

После UPDATE я получаю: «нет правила для создания цели», выполняющей MAKE, почему?

Я часто запускаю диспетчер обновлений Ubuntu , и после этого каждый раз мне нужно сделать make чтобы переустановить мой драйвер ТВ-тюнера ( как описано здесь ) Но в это время make остановки с ошибками: Следующие сообщения об ошибках переводятся с французского $ make make -C /lib/modules/3.2.0-53-generic-pae/build M= modules make[1]: entering in folder « /usr/src/linux-headers-3.2.0-53-generic-pae » […]

Обновление уведомления не работает

Уведомление об обновлении не уведомляет меня, когда доступны обновления. Когда-то у меня была аналогичная проблема, и это сработало: sudo rm /var/lib/update-notifier/dpkg-run-stamp sudo rm /var/lib/update-notifier/updates-available sudo rm /var/lib/apt/periodic/update-success-stamp Но в этом случае это не работает: sudo /usr/lib/update-notifier/update-motd-updates-available –force E: Unknown error: «<class 'KeyError'>» ("The cache has no package named 'wine1.7-i386'") Я также пробовал: sudo apt-get clean […]

Не удалось обновить Ubuntu 15.10

Я не могу успешно запустить sudo apt-get update за последние несколько дней. При запуске sudo apt-get update из терминала он показывает ошибку как, W: Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/wily/InRelease Unable to find expected entry 'main/binary-i386cddcd/Packages' in Release file (Wrong sources.list entry or malformed file) W: Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/wily-updates/InRelease Unable to find expected entry 'main/binary-i386cddcd/Packages' in […]

PyGIWarning, когда sudo update-manager -d

У меня есть неполная установка? $ sudo update-manager -d sys:1: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded. sys:1: PyGIWarning: GdkX11 was imported without specifying a version first. Use gi.require_version('GdkX11', '3.0') before import to ensure that the right version gets loaded. […]

Virtualbox * Нет подходящего модуля для запуска ядра

Раньше у меня был ubuntu 15.04. Я установил ubuntu 14.04 LTS, поскольку мне сказали, что 14.04 был стабильным. Теперь, когда я пытаюсь установить Virtual Box, эта ошибка отображается: vatsa@code-8-21:~$ sudo apt-get install virtualbox Readingpackage lists… Done Building dependency tree Reading state information… Done The following extra packageswill be installed: virtualbox-dkms virtualbox-qt Suggestedpackages: virtualbox-guest-additions-iso vde2 Thefollowing […]

software-properties-gtk сбой при запуске Ubuntu 16.04

Примерно через пару дней Software Updater не будет предупреждать меня об обновлениях. Сегодня утром я узнал, что software-properties-gtk несколько раз сбой при запуске системы, и если я попытаюсь запустить его с терминала, он завершит следующую трассировку: Traceback (most recent call last): File "/usr/bin/software-properties-gtk", line 37, in <module> from softwareproperties.gtk.SoftwarePropertiesGtk import SoftwarePropertiesGtk File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 54, […]