Темы Unity не будут применяться, если я не выйду из системы и не войду после загрузки

Я использую Unity Tweak для применения темы Libra с темой иконок Numix. Но каждый раз, когда я загружаю Ubuntu, я должен выйти и снова войти в систему для тем, которые будут применяться.

Интересно, в чем проблема? Я использую Ubuntu 14.04.2.

Обновление: проблема, похоже, связана только с оформлением окна. Внутренний вид окон прекрасен, кроме внешнего оформления. Также проблема с иконкой, кажется, только с Unity Launcher. Все иконки повсюду применяются.

Обновление 2: я забыл упомянуть, что я использую тему v1.1 темы Libra, которую я вручную извлек в мою / usr / share / theme, и должен сказать, что она действительно работает нормально, и мне просто нужно выйти и войти снова за то, что он ударил.

PS В любом случае я могу вручную перезагрузить диспетчер тем? Просто хочу посмотреть, исправляет ли он его без необходимости выхода из системы.

Вероятно, проблема заключается в том, что 14.04 (с GTK 3.10) не указана в списке поддерживаемых из этого источника. V1.1 говорит, что это для 14.10 (с GTK 3.12), а v2.1 говорит, что это для 15.04 (с GTK 3.14), что использовать новые (и разные) версии GTK. Эта страница, похоже, является источником расширения, но, похоже, перечисляет только версии на указанной вами странице.

Эти версии должны по-прежнему работать в некоторой степени (1.1 может работать лучше, чем 2.1) , но, вероятно, будут иметь проблемы, подобные тем, которые вы описываете. Проблемы также могут быть вызваны отсутствием необходимых GTK-движков («murrine» и «pixbuf» в этом случае).

Тем не менее, вы должны иметь возможность найти версию темы, которая работает в другом месте, например, используя тему noobslab themes PPA, как предлагается здесь :

 sudo add-apt-repository ppa:noobslab/themes sudo apt-get update sudo apt-get install libra-theme 

Вы также можете скачать файлы deb из этого PPA прямо здесь . Версия для trusty может быть только версией 1.1 темы, не исправленной, поэтому использование ее непосредственно из источника расширения или загруженного вами файла может привести к аналогичным результатам. В основном не используйте тему v2.1.