USB-мышь не работает после отсоединения в 14.04

Моя мышь Nox «Krom Kull» не будет работать (кроме фонарей) на моем ноутбуке, когда я отключу ее от сети, а затем снова подключите ее к «Ubuntu 14.04».

Я пробовал использовать старую мышь «Razer», и она работает. Я также помню, что это не проблема месяц или два назад, так что это может быть связано с недавним обновлением Ubuntu. И из-за недавней механической проблемы с этой мышью мне была дана новая одна модель, которая также не работает. Модель и обновление ОС, по-видимому, являются лучшим кандидатом в качестве источника проблемы.

Ноутбук – это «Alienware m17r4».

Благодаря!

Попробуйте перезагрузить драйвер мыши с помощью

sudo rmmod usbhid sudo modprobe usbhid 

когда мышь подключена и не работает.
Если это помогает, попробуйте добавить usbhid в конец файла /etc/modules и перезагрузитесь. Это своего рода шаманский язык, поскольку он не должен иметь никакого значения, но часто помогает с непризнанными флэш-накопителями.
Если это не помогает, вы можете создать правило udev для перезагрузки модуля мыши при подключении мыши.

попробуй это

 echo "on" | sudo tee /sys/bus/usb/devices/usb*/power/control 

затем перезагрузитесь. меня устраивает.

Это происходит потому, что управление питанием отключает устройства USB, чтобы сэкономить электроэнергию после определенного периода бездействия. Хотя есть решения для решения этого вручную, я рекомендую установить программное обеспечение под названием tlp.

 $ sudo add-apt-repository ppa:linrunner/tlp $ sudo apt-get update $ sudo apt-get install tlp $ sudo tlp start 

Я столкнулся с аналогичной проблемой при обновлении с 15.10 по 16.04. Мышь будет работать в течение 5 секунд, а затем перейдет в спящий режим и не будет работать снова, если я не нажму кнопку. Моим решением было удалить энергосберегающий пакет, предназначенный для ноутбуков, а затем перезагрузиться:

 sudo apt remove laptop-mode-tools sudo reboot 

У меня была та же проблема, и исправление было просто супер!

Перейдите в раздел Системные настройки -> Редактор настроек

Затем вы получаете диалоговое окно, слева – «указатели», поиск виртуальной мыши, а в «свойствах» вы получаете «Device_enable» со значением 0. Измените значение на 1, а затем вы закончите !!

Дайте мне знать, если это сработает!