Не удается установить uwsgi

root@ip-10-194-97-94:~# apt-get install uwsgi Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: uwsgi: Depends: uwsgi-python2.6 (>= 0.9.6.5-0ubuntu1~lucid1) or uwsgi-python3.1 (>= 0.9.6.5-0ubuntu1~lucid1) E: Broken packages 

uwsgi не находится в репозиториях по умолчанию. Вам необходимо добавить PPA (Personal Package Archive) и обновить источники:

 sudo add-apt-repository ppa:uwsgi/release sudo apt-get update sudo apt-get install uwsgi 

uWSGI плохо упакован. Вы должны либо установить uwsgi-python либо uwsgi-python3 . Все остальные пакеты отмечены как « Conflicts , которые совершенно сбивают с толку и, безусловно, ошибочны.

Первоначальный текст :

Перевод с использованием Google Translate : лучший способ

 sudo add-apt-repository ppa:uwsgi/release sudo apt-get update sudo apt-get install uwsgi-python