Intereting Posts
Wireshark захватывает только пакет с и на мой компьютер, когда он находится в беспорядочном режиме Август LP205R на Ubuntu GNOME 15.04 Ранее было обнаружено мобильное широкополосное устройство, но теперь уже не больше VMware больше не компилируется после обновления Bluetooth-мышь отстает и в конечном итоге отключается Как автоматически отключить звук в наушниках? Или как подключить скрипт bash к системному прослушивателю событий? Как установить старые драйверы AMD Catalyst 12.4 на Ubuntu 12.10? Лучший способ обновления ядра в Ubuntu Desktop 14.04.3 LTS проверяя, какие предыдущие версии пакета были установлены или проверяли записи транзакций для apt Как увидеть доступные беспроводные сети на 12.10? Ubuntu 14.04 / 15.04 & Skylake I5 6600k / Intel HD 530, графические проблемы Как выделить только имя (а не расширение) для переименования? Как автоматически оставаться в курсе последних версий основного ядра? sun-java6-plugin не имеет кандидата на установку? Как вы пишете макрос для специального символа в LibreOffice?

wine: x файлы разработки не найдены

Я загрузил wine-1.4-rc5.tar.bz2 . Я запустил tools/wineinstall в терминале. Через некоторое время я получаю эту ошибку.

 checking for X... no configure: error: X development files not found. Wine will be built without X support, which probably isn't what you want. You will need to install development packages of Xlib/Xfree86 at the very least. Use the --without-x option if you really want this. Configure failed, aborting install. 

Установка не завершится. Могу ли я исправить это и сделать Wine install?

Большинство людей должны либо установить Вино через официальные репозитории Ubuntu, либо использовать официальный Wine Wine PPA .

Однако, если вы хотите создать и установить Wine из источника, вы должны это сделать.

  • Это может иметь смысл, если вы хотите установить более позднюю версию Wine, чем это предусмотрено для вашей версии Ubuntu. Однако, как отметил BuZZ-dEE , хотя в официальном PPA нет пакета wine1.4 для Ubuntu 10.04, пакет wine1.3 фактически предоставляет версию 1.4. (Это указывается полным номером версии – 1.4-0ubuntu1~ppa1~lucid1 – и его можно проверить, просмотрев файл VERSION в файле wine1.3_1.4.orig.tar.gz который wine1.3_1.4.orig.tar.gz здесь .)

    Поэтому ответ Buzz-dEE – совет Бога; Я рекомендую вам просто использовать этот пакет, если у вас нет конкретных потребностей, которые требуют от вас компиляции из источника. (Или вы хотите использовать нестабильную версию 1.5, которая не предоставляется для Lucid.)

    Однако, если по какой-либо причине вы хотите построить из источника, пожалуйста, прочитайте.

Вам понадобятся пакеты разработки, которые предоставляют файлы заголовков для библиотек, которые он использует. В этом причина сообщения об ошибке, которое вы получаете.

Чтобы устранить эту ошибку, вам понадобится пакет libx11-dev .

-dev пакеты содержат файлы заголовков. libx11-dev – не единственный такой пакет, который вам понадобится, чтобы скомпилировать Wine из источника. Я рекомендую взглянуть на зависимости сборки для версии разработки Wine в Ubuntu . (Прокрутите вниз до места, где указано «Объединить зависимости».) Это должно дать вам представление о том, -dev пакеты -dev вам нужно установить, чтобы Wine смог скомпилировать.

Если вы используете 64-битную версию Ubuntu, это сообщение об ошибке может появиться, если вы пытаетесь скомпилировать 32-битное вино, поэтому для этого вам понадобится 32-битные библиотеки : libx11-dev:i386 и libfreetype6-dev:i386

Если у вас есть исходные репозитории, вам будет больше удачи, если вы используете:

 sudo apt-get build-dep wine 

Он устанавливает все зависимости Wine. Если вам нужно только решить ошибку X:

 sudo apt-get install xorg-dev libx11-dev