Как получить xfce4-volumed для работы в Lubuntu?

Я хочу использовать xfce4-volumed в Lubuntu, потому что мне нравится всплывающее уведомление об объеме, которое оно дает при изменении громкости в Xubuntu. Lubuntu до сих пор не хватает этой возможности.

Просто установка xfce4-volumed в Synaptic Package Manager не работает: запуск xfce4-volumed в терминале не покажет мне ожидаемое всплывающее окно при изменении тома. Терминал не похож, что на самом деле ничего не работает: он сразу дает мне новое приглашение (ваше имя @ ubuntu: ~ $) вместо того, чтобы показывать какой-то журнал отладки.

Я также попытался установить xfce4-mixer . Эта программа действительно запускается, но она все равно не даст мне xfce4-volumed -popup при смене тома, даже в сочетании с xfce4-volumed .

Как я могу заставить xfce4-volumed работать?

Вам понадобятся некоторые предварительные пакеты:

 sudo apt-get install xfce4-volumed gstreamer0.10-alsa 

xfce4-volumed – это демон, который требует, чтобы плагин gstreamer-alsa работал. Обычно это запускается при запуске.

Тем не менее, для тестирования я просто запустил xfce4-volumed из lxterminal .

Если вы затем используете стандартный регулятор громкости, вы увидите всплывающие окна – вам также потребуется очистить конверт уведомлений в системном трее, чтобы увидеть дополнительные всплывающие окна.

введите описание изображения здесь

Тем не менее, при тестировании я обнаружил, что xfce4-volumed был довольно темпераментным – иногда он переставал работать, и единственный способ заставить его начать снова – это выйти из системы и войти в систему 🙁